Lab Ordering Performance Issues

Incident Report for Akute Health

Resolved

This incident has been resolved.
Posted Nov 29, 2025 - 11:25 CST

Investigating

We are currently researching and monitoring reported performance issues using the Lab Ordering Module interface. Users are reporting that the lab ordering process is taking longer than usual to complete.

Akute has, in conjunction with our partners, identified the initial cause of the performance issues and we are working to resolve the issues.
Posted Nov 26, 2025 - 16:06 CST
This incident affected: Lab Ordering/Results.