Appointment Updates Not Working
Incident Report for Akute Health
Resolved
This incident has been resolved.
Posted Mar 04, 2024 - 11:31 CST
Update
We are continuing to monitor for any further issues.
Posted Mar 04, 2024 - 10:02 CST
Monitoring
We discovered a recent update caused appointment updates (such as updating appointment status) to not allow you to save. We have since identified and fixed the bug.

We recognize how vital the scheduling tool is to your operations and sincerely apologize for the issue. Please let us know if you continue to experience any issues.
Posted Mar 04, 2024 - 08:02 CST
This incident affected: App.