Slow loading tasks
Incident Report for Akute Health
Resolved
This incident has been resolved. We scaled up our server instances to better handle the load. In addition, we will implement better controls to prevent this slowdown in the future.
Posted May 17, 2023 - 14:00 CDT
Identified
We've identified an issue with tasks loading slowly and are working on a fix.
Posted May 17, 2023 - 13:48 CDT
This incident affected: App.