Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 24, 2024 - 04:45 CST
Scheduled
Labcorp has scheduled system maintenances during the month of November, including Sunday Nov 24 from 5:45 am ET - 8:00 am ET. Please be advised that during these maintenance events, you may experience brief minor connectivity outages. You will be unable to place orders or receive results during this time. Any pending results will be resent after the outage window.
We apologize for any inconvenience this may cause to your EDI connectivity. If you have any questions or concerns regarding this notification, please feel free to contact edisupport@labcorp.com.
Posted Oct 28, 2024 - 11:54 CDT
This scheduled maintenance affected: Lab Ordering/Results.