Eprescribe Down
Incident Report for Akute Health
Resolved
This issue has been resolved. A browser refresh may be required to resolve the issue.
We apologize for the inconvenience this issue may have caused and are continuing to work with our partners to improve the reliability and experience.
Posted Mar 22, 2023 - 12:40 CDT
Investigating
We are investigating an issue with our eprescribe application not working.
Posted Mar 22, 2023 - 11:52 CDT
This incident affected: E-prescribe.